Twitch streaming: put playfield view on the left side


#1

For all of us iOS users, it would be awesome to have the playfield view on the left side of the stream window, so that the chat sidebar doesn’t obscure the all-important view of the playfield. Like what geekgamerTV is doing for the NW Open. https://www.twitch.tv/videos/301426800?t=1640s


#2

Speaking of twitch. How in the world do you get it to not stutter every couple of seconds? I’m hard wired in at 300 megs download on a PC with a 2 gig video card, I5 Processor and 8 gigs of RAM. While not a powerhouse it should be able to handle streaming of this nature. Always been this way so I avoid Twitch all together.


#3

You could try the Twitch a desktop app instead of the web page, or do what I do and just stream it from your phone app to your screen via Apple TV or screencast or whatnot. There’s also apps like gamestreams for LG smart TVs.


#4

Edit. Duh you’re watching not streaming. Sorry.


#5

I have a six year old Dell desktop with specs far inferior to yours, and never have a problem streaming Twitch (or any other site), so I doubt your problem is hardware related. I’m wired to the default AT&T U-verse router. Other household devices (Roku, iPad, iPhones) stream Twitch fine via Eero wifi.


#6

Interesting. I’m fairly new to watching on twitch (about 1.5 years) and it’s never worked. I just don’t even try anymore. I wonder what the issue could be. Everything else works great, including watching on sites like youtube otherwise I’d consider a virus of some sort (have Norton). Open to suggestions as their is a lot of good pinball stuff on twitch that i can’t watch.


#7

What happens when you watch papa live streams on YT?


#8

Perfectly smooth, just like watching TV. Only Twitch does this video stuttering issue. Sounds is always is fine to, it’s just the video.


#9

Which browser and operating system?


#10

Firefox is primary but it does it on Chrome as well. I’m on windows 10.


#11

Odd, was thinking maybe it was a decoder issue but both of those should have them and work fine. Maybe try an incognito window? Perhaps it’s a plugin like ad block or something?


#12

I have no issue streaming (viewing) Twitch for years now on Chrome. Using Windows 7, I get clear smooth video. And my internet speed is far slower than what you listed.


#13

As mentioned above, get the desktop app. On default settings, it automatically adjusts the video to the quality it’s streaming. You can also turn the video quality down, if needed.

For ipads, the app is a no-brainer. It allows you to enlarge the video so the playfield fits as big as it possibly can. Not sure if the desktop app does the same thing, but it’s certainly the first thing you should try if you’re having video trouble while viewing with a browser. The app is free.


#14

Responding to the OP… Yes, I think it would be a brilliant idea to have the playfield on the left and the other stuff on the right. Precisely because, otherwise, the chat pane obscures the playfield.

I usually watch Twitch streams without the chat visible because of this. Or I can watch the chat and miss most of the action…


#15

Here’s what mine look like with the chat pane open. Am I missing something? Looks like nothing is cut off.


#16

In the iOS app, the chat panel will either (1) shrink the whole video to fit the panel on the right side or (2) overlay in a translucent panel over the right side of the video.

edit: You can switch between them with iirc a double headed arrow in the upper left when the chat panel is visible.


#17

Think that is the biggest difference. None of my Windows7 computers have issues. Just this one, which came with windows 10 :frowning:

I’ll try the desktop app suggestion.


#18

If you are using Chrome, try turning off hardware acceleration.

Settings -> scroll to bottom -> Advanced -> System -> “Use hardware acceleration when available”


#19

This sounds like the same symptom I had when Twitch was pulling down a 60fps stream and my monitor was showing 30fps. Can you try playing with the video quality settings while watching? It seems to default to 60fps when available, even if your display is running at 30. Any of the quality options that don’t explicitly mention 60 should be 30.

It appears as if Twitch is showing every 60fps frame, at a rate of 30fps, then every few seconds it’s like “oh shit I’m behind lemme drop the next 100 frames to catch up”. I don’t see this happening on YouTube though, FWIW.

Alternatively, you could try getting your display running at 60fps. This was a hassle for me to get working, but if your monitor is better than mine (i.e., doesn’t forget settings every day) and you watch a lot of pinball, it’s worth trying out. 60fps pinball feels a lot easier to follow.