Tech: RBION reboots when coil fires

This is an odd one and I’m currently not sure how to proceed. I have a Ripleys that is rebooting but only under the following condition…

Start game
Light lock
Lock balls
Shoot multiball start

At this point the animation plays but when the coil should fire the locked balls out, the game immediately reboots. The game will then continue to be stuck in a loop of rebooting until the balls are manually returned to the trough. I assume this is because every time the game boots it attempts to fire the coil that would eject the ball/s from the lock lane. Unplugging the coil does not eliminate the problem so it has to be some sort of board related issue I think. I have tested and replaced the driver transistor for the coil and I’ve even tried replacing the flip flop 273 chip associated with that coil but the problem persists. The only other clue I have is that at some point, there were a number of bad opto boards that were replaced in this game so I think the opto section had burned out in the past, I don’t see any signs of board work other than my own and it seems to be running an older ROM version. All voltages are solid and strong. Board set looks to be in great shape. :head_bandage:

It’s a bug. Turn off high pulse coils


Ugh. So much wasted time on this for a stupid software bug but at least it works now. Thanks!!

Ripley’s has some weird bugs. If you’re on older code, get something at least new-ish. I think I have 3.10 on mine and if you set Asia to require more than 30 switches to complete, the game will reset with a shot to the vari-target. Under 30, no prob. It does still have the Go Backwards award from the scoop though. Don’t think that’s in 3.20.