Some technical forum issues


#1

Posting in “Meta” here, mainly addressed to @heyrocker, but maybe other people want to chime in, too.

1.)

There’s a very weird issue with specific user name mentions, case sensitivity and ad blockers. Mentioning @Adam in a post will link to http://tiltforums.com/users/adam. Going to that URL without adblock works. With adblock on (uBlock Origin in Chrome), I’m redirected to 404. Changing the URL to match the actual case sensitive user name (http://tiltforums.com/users/Adam) works, though.

I’ve disabled my redirect caches and tried it with a fresh private tab, with the same results. I’ve tried some other user names with uppercase letters, and none of those had this problem. I’ve reproduced the issue on a different machine with a similar setup. Can anyone else reproduce this? Am I hallucinating?

2.)

I think embedded twitch videos should definitely not autoplay with audio on. Muted autoplay, ok, but nobody wants some embed blasting the speakers while browsing a forum.

Edit: Looks like the video autoplays regardless of whether it’s actually visible. If I’ve already read the thread and just go to the last reply (e.g. How does he do this?), playback from the first post will still start, without any immediate means to stop the audio. I think this is a high priority issue.


#2
  1. Confirmed that it works/doesn’t work the same way for me.

  2. Agree.