Is there a trick to getting this site to load up? I’ve been trying for several days both on a pc as well as my phone and can never get past the 3 bar loading icon, even after hours of having the site address open. Help!

1 Like

Works for me, and hasn’t had a problem lately.

Odd that you have the issue on multiple devices.

try a different browser

That wouldn’t work because…

I’ve tried chrome, Firefox, and ie, cleared all cache cookies etc, still just get loading icons, guess I can’t use the site

Weird, reloaded Firefox and was able to get in, defiantly doesn’t like chrome on android

Working just fine in Chrome on my Galaxy S6.

Are you behind a proxy of some sort?

1 Like

That’s the most likely cause. Pinballvideos loads its main guts from so if your proxy blocks anything but the classic ports (80, 443, 110, 25, 8080, etc) that would prevent the website from fully loading and you’d get the infinite loading bars.

You can check if it’s the case by right clicking anywhere in Chrome, choose “inspect” , then go to the “network” tab of the developer tools that will open and check for any red/still loading items (you’ll probably see the “app” item in this state).

Actually, if you click the link above and it doesn’t load (it choose display javascript gibberish ;-)) you have your culprit.


That could very well be the reason. The data routes sit behind a varnish cache, that’s why they use a different port. I should probably handle this sort of failure more gracefully.

You could just swap the ports.
Run the app on whatever exotic port you want and run Varnish on 80

1 Like

There are other things running on 80 (or 443 that is) which I don’t want to swap to an exotic port either. I moved everything to 443 now and let nginx decide what to put through varnish.

Pinging @h2omonkey, please try again and let me know if it works now.


That worked, was able to get it going on the pc using chrome, thanks