NBA Fastbreak Ball Save Bug?


#1

Anyone noticed that NBA running the last 2.3 ROM will not light or award a ball save for P1, B1 in a 4 player game? My game is doing this much to the frustration of a couple league players and I thought it was nonsense until I started a 4P game and tried myself. Works fine for 2 and 3 player games and works fine for ball 2. A factory reset did zilch. Known bug? New bug? Nothing I can find online recerences this.


#2

I think there’s a similar or identical bug for NBAFB when it’s set up as a linked pair, but not playing a linked game. I haven’t seen this bug when I used to have NBAFB. I know you did a factory reset, but maybe dig through settings and make sure that any linked settings are turned off, if there even is such a setting.


#3

Latest and greatest looks to be version 3.1, although no one, including Planetary, seems to have the revision history. If no other suggestions, try upgrading to 3.1.


#4

The doc I looked at had 2.3 as the last revision but looks like there is a 3.1 on IPDB. Interesting. I’ll check that out and look for any link setting that may be enabled.


#5

My mistake, Planetary does have the revision history. Link didn’t look clickable.

http://www.planetarypinball.com/mm5/Williams/tech/roms/fastbreak.html

Nothing on the bug you’re seeing, but may be worth a shot. The link below should be at least as accurate as IPDB for WPC game code. Revision history is the valuable stuff.

http://www.planetarypinball.com/mm5/Williams/tech/wpcroms.html


#6

Checked setting for linking and everything was as it should be for un-linked games. I’ll order a new ROM and report back.


#7

Just tried it. Rev 2.3. Four player game. P1, B1, ball save lights and it saves the ball for me.

Maybe a switch on the playfield is triggering and the ball save is timing out before ball launch?

Maybe go through the switch test and see if you get any phantom switch hits (with balls removed). I had to fix a mis-wired diode on one of the 3-P-T standups that would phantom trigger trough opto 1. It only caused problems in midnight madness when all 4 balls were in play. Just saying maybe you have an obscure problem like this.


#8

I did run through switch test and look for anything that seemed awry but it can’t hurt to double check. I thought if a switch hit were the issue, it would be inconsistently timing out the ball save for all players, or consistently for every player. That it only ever does this for P1/B1 in a 4 player game, lead me to believe it would have something to do with software.


#9

I was thinking maybe the start button switch is causing a phantom switch hit, but then it would affect a 2 or 3 player game also, unless the playfield validation requires several switch hits.


#10

Correct. The bug was discovered on our linked fastbreaks. If you are playing a non linked game on a pair of linked fastbreaks it does weird behavior with player 1’s ball saves. Was this fastbreaks ever set up to be linked?


#11

It may have been but not by me. I’ll have to see if if has the extra EPROMs on the sound board. I’m also going to try pulling the batteries to see if the full reset changes anything, I did it through utilities before.

Edit… just checked the switch matrix again and it’s fine. There are no extra chips installed for linking either. I think I probably need to just try a new ROM at this point.


#12

Is it the Rom Revision needed for the linked fastbreaks?


#13

Do linked Fastbreaks have a specific ROM? I think it’s programmed in to most of the revisions provided the hardware is present.


#14

The linking kit includes two EPROMs.
https://www.ipdb.org/files/4023/Bally_1997_NBA_Fastbreak_Linking_Kit_Installation_Instructions_for_Linking_Kit_58030.pdf


#15

Yes but linking is supported from revision 2.1 of the G11 EPROM and @JShop reported above that he could not duplicate the bug with the same ROM revision (2.3) I have currently installed.


#16

I don’t know about these extra chips that need to be added to link games or how that affects things. Mine just says rev 2.3 when I start it up. I haven’t checked to see if it has U22 or U24 chips, but I’m guessing not. @jay, does yours have these extra chips installed?


#17

None of the chips for linking are installed in it.


#18

I recently updated this game to ROM version 3.1 and the bug persists. The game came to me with a new CPU board in it (Rottendog I think) so I’m going to try swapping it with another game to see if there’s something there. About all I can think of at this point.