Known bugs?


#22

Any ideas what happened, I participated a tournament yesterday and played Road Show. My opponent lost his ball (long ball, like 4-5minutes), it was on single ball play but for some reason game gave him new ball on shooter lane. Like ball save was on or something. Where you can get ball saver on? I can’t recall anything, but my knowledge on RS is little shallow.


#23

Road Show is infamous for phantom ball saves. No particular rhyme or reason that I know of, it just occasionally decides to give you a ball save when you drain.


#24

Sometimes it happens on a bulldozer hit, other times it happens on the right-return (where the skill shot is), it has some code to dodge the soft-plunge to right outlane like Funhouse has.

But yeah, that game has some weird weird ball saves at times.


#25

Thanks for the clarification! It’s a little pity, I really like RS and sure like to see it on tourneys lineup. Actually I have played “real one” very little, Pinball Arcade helped “a bit” with the rules. After really getting into rules and generated somekind of strategy, I got over billion with the first game when got the change to play. Anyway, it’s shame that many good games has some kind of flaws in software that can even ensure that it will never be used in competition.


#26

Has anybody ever observed the following bug on Circus Voltaire?

On Free Play, the ringmaster will normally award hits on both the yellow stand-ups as well as hits to the ringmaster (opto registered hits). On coin drop, the ringmaster head will not register any hits and only stand-up hits will advance progress on the ringmaster shot.

We investigated this issue for a long time at a small arcade in State College, PA but were not able to figure out why it was happening. Assuming it’s a software bug since as soon as the game is switched into free play all ringmaster hits worked fine.


#27

Ringmaster doesn’t use optos, it uses (I believe self-adjusting) proximity sensors.

I believe the firmware on those boards isn’t the best. I don’t think it’s a game software bug, the problem more lies with the auto-adjustiness of the proximity boards.


#28

Here is a weird one we saw last night on Radical!, I’m wondering if it is well known. I was working on my third multiball in a very long game, with one ball locked. I airballed into the lock lane and multiball started. It did the jackpot animation, telling me my jackpot was 9M, then both the balls kicked out. However when I collected the jackpot, I was not awarded the points for it, the ball was not diverted to the lock lane, it appeared that the game had fallen out of multiball and back into normal play? Is this a normal side effect of the lucky multiball start?


#29

This is not a normal side effect of the multiball start: as far as I know (which isn’t much?) that doesn’t induce extra nonsense. I think it’s a normal side effect of the ball not diverting, though what caused that is ??? Was the mega-millions insert flashing?

Did you get the 9M? There’s some chance the game gave you the 9M already and you were around to the re-light-millions logic rather than the multiball start?


#30

Funny, I just had a similar thing happen to a player last night.

Player was in multiball, jackpot was lit, and he successfully shoots the ramp to claim the jackpot. Jackpot animation happens, but ball does not get diverted back to the lock properly, and game fails to award him points for the jackpot.

Not sure if it went back to single-ball play, since the game acts pretty similar to single ball play after you hit a jackpot and stay in multi-ball.

I had just fixed a similar issue on F-14. The upper diverter was failing intermittently. This meant that sometimes when you would hit the right saucer for “Release” or to collect the Fighter Jackpot, it would play the callouts for the appropriate award but not award multi-ball or jackpot points. This happens because the game doesn’t award the points or multiball unless the ball is diverted to the proper saucer. Fixing the diverter solved this problem.

Anyways, because of what I learned on F-14, I took off the glass while he was still cradled up with both balls, and tried triggering the switch on the left ramp return just past the diverter and also placed one of his balls in the ball lock, thinking this might award those points. All this did was award him the lit “million” for hitting the upper right ramp, and kicked the ball back out of the lock.

I suspect the switch on the upper left ramp entrance may be flaky, since that is the only switch that would trigger the diverter from that shot. I’ve also experienced it diverting the ball to the left ramp return in the middle of a Tailslider round, which seems like it could be related as well.

I’ll be at the location of my RAD! today working on various things and will report back if I find anything.

For the record, I’m running the tournament ROM that always awards 5m for jackpots.


#31

No I absolutely did not get the 9M. However the Mega Millions insert was not flashing anymore either, so it knew something had happened. Blah.


#32

FWIW, the switch that is triggered by the diverter when it is in the “down” position needed adjustment. It was not being triggered at all. Not 100% sure if this was the cause, but I wouldn’t be surprised.


#33

As in, not after 1+N tailsliders, where N is the number of rounds completed already?

I’m pretty sure that is. If you shoot the left ramp (or plunge it) softly enough to go left (to the lock) without the diverter engaging, you get a million.


#34

I’ve actually never been sure what dictated how many tailsliders it lets you make. Can you explain what is meant by “rounds”?

Definitely true


#35

At the start of the game, you can shoot 2 tailsliders before it diverts. If you do that, then you can shoot 3 tailsliders. Every time it diverts from a set of tailsliders your ‘count’ goes up by one.


#36

I recently checked the ROM version on a sited Getaway we use for tournaments. It says L-6 when it boots. Does anyone know what’s different in that ROM? I’ve come up empty in my searches.


#37

So I followed these instructions in an attempt to see if I could reproduce this glitch last night for fun. I lit multiball, started snack attack, and then started multiball. I then quickly drained out of multiball without hitting any shots. On my following ball nothing happened. Is there a timing thing as far as how long to let snack attack run down before starting the multiball? Or like you said, do you have to drain directly to bonus from multiball? There may have been a second or two of the restart animation.


#38

We’re getting a Hook at the bar that’s my team’s home bar for pinball league. I may have played this game once ever. Could someone please explain this scoring convention for me?


#39

The points scored in croc time are added to your bonus. The scoring goes something like 5mil for 1st shot, then 10mil, then 10mil, etc. You can get this multiple times on any ball.

Where it stiffs you is that if you were to score 105mil - it will only award you 5mil.

I’m certain there’s another scoring feature that stiffs you in the exact same way on Hook, but I can’t remember. It’s probably the most disliked game I’ve ever had in my collection. After less than a day I wanted rid of it.


#40

Holy hell. I didn’t know this. So there goes my scoring strategy on that game since I cannot hit the wind coaster ramp.


#41

All this is fixed in 5.0, which sadly is not available right now. Hopefully pinballcode.com will get it resolved soon (Is Chad on here?)

http://www.pinballcode.com/hook5