Iron Maiden Pinball Rulesheet (WIP)


#746

Does it not depend how you drain, centre drain as opposed to outlanes?


#747

Thanks, I think this is accurate. Tested this by having level 3 mystery lit and also all the locks lit for first Trooper multiball. The drops then kept only giving out bonus X’s skipping the other awards.

Still not sure if mystery can give out extra balls. The backstage pass rules PDF states that EB can be a “random ORB award (percentage adjustment)”, but maybe the location game I’ve been playing just has given out that many other EBs that I haven’t seen it available there. On the other hand, the backstage pass rulesheet doesn’t mention the loop EBs, so it also could be that these two have replaced each other?


#748

Loop EBs were likely just coded in a later revision after the Backstage Pass was made.


#749

Yes, this is correct.

Right now it is a feature. In a future update I may add an adjustment for that.


#750

Tried going through this thread and seeing if this was mentioned but didn’t see it (probably overlooked) but I’ve got a couple bugs to report and a plea for assistance on a game challenge.

Challenge - Fairly often in MB I can lock a ball by shooting the left ramp (premium game). I believe this is on purpose but the game seems to lose track of that ball every time I do this. The ball is locking behind the back panel. Is their something I should look at that could be holding the ball back there? I thought it was supposed to come all the way to the piece that raises and lowers to allow the ball to go into the mummy lock mech.

Bug - My game seems to lose track of the number of balls in play when ever more than one ball is kicked out or in the above situation and it kicks another ball into play after a couple ball searches. Happened to me twice this weekend. By the time I got the key, opened the door and fished the ball out another kicked out and now the game kills the ball if I drain one. In a MB, if it kicks out 2 (instead of ) for revive or an add a ball. When I drain down to 1 ball the ball will end as the game didn’t account for the extra. If I try draining just 1 when this happens it kicks out another ball while the ball saver is on and still ends the ball if I cont to drain after ball saver is off. I’ve found this odd as my other sterns will account for extra balls in play being drained. Almost like it’s not counting the balls correctly. Is this a bug or an issue just with my game?


#751

Sounds like the ball is getting stuck on the switch behind the back panel. You may have to bend it down slightly to allow the ball to pass on a slow roll.


#752

I’ll give that a check tonight. Thanks for the pointer. For some reason I though that maybe their was an opto at that gate. Didn’t even think of a switch back there.


#753

Interesting Maiden scenario. So, locked two balls for Trooper and had all mummy locks so mummy mb was also flashing and ready to go. My next shot was an attempt to start mummy mb, so I hit the captive ball and then ball also swung left and into the trooper lock as it does sometimes. The game chose to start trooper instead even though technically mummy should have started, but plunged out 4 balls instead of three for trooper (I had five with the first add-a-ball) and completely took away all mummy locks after trooper was done even though I never played mummy. Bizarre!


#754

So, from @sk8ball

However, it looks like the second half of the sequence didn’t work for you. You should have gotten the 4-ball as planned, but not sure why the Mummy MB wasn’t still lit after you drained out of Trooper.


#755

Thanks for the info!


#756

I ended that ball (it was ball 3) pretty quickly after coming out of trooper multiball so it’s possible that it just hadn’t “caught up”. I don’t think it shows your mummy locks IN Trooper, but It had switched back to the Eddie letter chase/ normal gameplay if just for a moment and mummy locks were gone, but I did drain pretty quickly, so who knows…


#757

What does that look like?

You only lock one ball for Mummy MB. and the captive ball looks pretty similar on phase 2 compared to phase 1.


#758

When mummy mb is ready to go (as it was), the letters and the red insert are lit and strobing. It’s clear that mummy is ready for blast off. It was back to just one letter and no red lit insert so it wanted me to start the process of pounding the captive ball and locking the ball over entirely.


#759

Ah right!

Is this on a Premium or a Pro?


#760

This is a pro, fancy pants . I imagine therein lies the disconnect. :wink:


#761

No, it’s the opposite. I have a Pro and was starting to assume this was a Premium thing. I’m pretty sure I always see Mummy MB ready to go when I get out of Trooper that starts The Fun Way, but it’s probably been a while.


#762

That’s how it was “redesigned”. Initially 3-4 code versions ago, this was reported as a “bug” and instead @sk8ball liked that it included it in the code for the Pro. So, maybe @lam has discovered another bug.

@lam - which code are you on?


#763

I’m on the most recent code, but like I said I drained out of trooper pretty fast and even though I’m 99% sure everything went back to normal game play, it’s possible it had not. I had no other ball after that to confirm. Will try again tonight!


#764

On the premium you have to relock the ball before you can start mummy (at least that is what I’m trying to recall). Is it possible that the center shot was lit to virtually relock the ball so that Mummy could then be started?


#765

This was on a Pro. No virtuals to setup correct?