Another Royal Flush problem

I have a Royal Flush that I had just gotten working perfectly and now it suddenly has another problem. Upon adding a credit it begins its startup sequence and the reset unit inside the cabinet keeps running without stopping. Going through the startup sequence on Clay’s site, I have confirmed that everything in the backbox is happening fine, P5A and P5B are set properly, and the score motor does stop running. What happens after that is that relay KX continually tries to activate, and the bonus doesn’t reset. I have tried cleaning and adjusting the switches on KX but everything appears to be OK there. No obviously loose/hanging wires. Any thoughts on this one? Here’s a link to a scan of the schematics if it helps:

Heya, that’s the ridiculously large PDF that I made scanning my schematic. Amateur error. :slightly_smiling:

People can also try the faster JPG version

Back to your issue: Royal Flush was my first machine ever, so I don’t have it in front of me, but KX seems to be a latched relay: that is one solenoid pulls it, a springed ledge helps latch it, and another solenoid (KX Release) unlatches it.
That is to say, it is not a relay that would be impeding your reset sequence.
Other relays will have a NO (Normally Open) switch that will open when on, then the switch stays closed until the relay is released. KX is not like that.

When the motor is spinning and spinning, CHANCES ARE, 90%, that it is an adjustment on the AX relay. trust me on this. :slightly_smiling:
(9% of the other times, it is a zeroing issue with the reels and Z1 and Z2 relays!)

Look at which switches being closed makes the motor run: AX is there at the right, and is the crucial part of the reset sequence.
Clean the contacts and verify the gap of EVERY switch blade in there before going any further.

So if the KX is not resetting, when you do finally start a new game, the DOUBLE BONUS will still be on, but the game should technically start. At that point, you can focus on adjusting the KX to make sure it releases properly.

Good luck! I will try and check back to help, if I can.


What is your bonus unit relay doing? It’s that small disc unit that steps the bonus 1-5 then back to zero. If that isn’t stepping correctly it will do as you describe

1 Like

So I went throught and cleaned and verified AX, and no luck. AX is hard to deal with, however I cleaned all the switches and everything appears to be gapped properly. I also did the same with every. single. score. reel.

The bonus unit is not resetting, and doesn’t even appear to be trying to reset. When I move it by hand it works well and it isn’t gunked up, the relay just isn’t firing. What would cause that?

bad coil/connection?

Please confirm what you mean: The bonus STEPPER is not resetting?
Or the double bonus relay is not unlatching?

The bonus stepper is not resetting, nor even trying to do far as I can see. I moved it manually out of its zero position expecting it to reset and nothing,

When the bonus stepper is in zero position (you manually activate the reset relay, allowing it to go all the way back,) does the game start up?


What happens when you manually step up the player unit?

It seems to work fine, and I’ve verified that the switches are working properly in its home position (after the reels reset, which they all do successfully.)

I fixed it! I saw in the startup sequence that it says “When P5A closes, AX and BX reset through motor 2C and switches on U, O and R” so I went through and adjusted/cleaned U, O and R, and we were in business. So simple, but I think I tend to get overwhelmed when I’m working on EMs. Thanks everyone for the help and feedback, I really appreciate it.

Annnnnnd its broken again. Will startup fine, starts a new ball, plays the ball, but when you drain it won’t count the bonus. For instance, if you lit the “Jacks Or Kings” 1K bonus, it will sit there and count 1K, the bonus relay will click, but the bonus unit won’t advance and it will count 1K again. Repeat until … you have lots of points. It worked fine for about 10 games or so.

1 Like

Yank that thing out, its on a plug and clean/ lube it. Those relays are finicky

The bonus unit itself is actually in nice shape, it just looks like the relay isnt firing at all.

So switch in score bonus relay or score motor being flaky