Trouble updating the wiki


#1

Hey everyone. I’ve been trying to get the Batman 66 wiki updated to the new 1.0 code and made a few small edits before getting a “Sorry, an error occurred” message. After trying a few different things I think I narrowed it down to an issue with adding too much text before the existing text. I wanted to add a table of contents and move up one of the rule subjects but can’t seem to get it to work. I’m thinking the history/change log can’t deal with it. Anyone have any ideas how to work this out? Would I need to post it as a new wiki?


#2

@gdd, worth updating to the latest version of Discourse to see if perhaps that resolves the problem?

@Jahkub, as a workaround, have you tried inserting smaller blocks of text at a time, to see if that makes it any happier?


#3

Thanks @joe, that seems to work if I keep it around 20 lines or so. Certainly not ideal but it’ll get me there for now.


#4

Never mind, it’s still being mean, although I did get a couple paragraphs moved up.

Edit: Now it’s kinda working again… Hit or miss.


#5

The content on that post conveniently looks to be sitting just shy of 32kb, so it might also be an nginx config issue.


#6

Interestingly I can’t even seem to add even typed text to the bottom of the wiki at this point. Maybe I hit a maximum file size or something? I just want to update all the progress I’ve made. :cry:


#7

The client_max_body_size defaults to 1m; if it is set to 32k, I’d think it would block almost all attachments. :slight_smile:


#8

proxy_buffers defaults to 8 * $pagesize which ends up at 32k on x86 (and x64) systems. There are also a handful of other fcgi related tubables that could factor in. Of course without looking at logs we’re just speculating based on funny sized numbers, and talking out our rears :slight_smile:


#9

I completed an update a couple hours ago.


#10

There have been some issues at my hosting provider and we’ve been running short on disk space, so those were more likely culprits. I am hoping that stuff is more stable now.


#11

Great! Thanks for all you do here, I’ll give it a shot soon!
I’m not sure if I still have the issue yet but I think it might be the wiki itself failing to understand where to highlight the changes in the log when I dump a big block of text into it. Would that make sense to any of you?


#12

Still not working :confused:


#13

Out of complete frustration I figured I’d try to start a new “v1.0” rule sheet post for BM 66 and discovered the real problem with editing the current one. The error message when I tried to make a new post was “Body is limited to 32000 characters; you entered 48564.”

Soooo, I guess I can’t post my edit here unless the character limit is raised. I did put a lot of time into this and it would be a shame to pare it down so much.

Any thoughts on this @gdd?


#14

Parts 1-x as needed, in a new thread.


#15

Only the first post of the wiki is editable, so that would get unwieldy. I think the better solution is for @gdd to up the max_post_length default from 32000.


#16

I have doubled it to 64000


#17

AHHHHHHHHHHHHHHHHH, finally works!

Thanks for doing that!